Sistemi di virtualizzazione
 

Problema datastore iSCSI 10Gb + VmWare

SAP 22 Lug 2015 11:46
Ciao a tutti, riporto il messaggio di un amico in difficoltà:

Salve a tutti, è qualche giorno che stiamo facendo dei test per
migliorare l'infrastruttura di rete aggiungendo un datastore full SSD su
cui mettere la cache o direttamente le macchine, avendo un cluster con 3
HOST abbiamo optato per un synology Rackstation 3614xs+ con 6 SSD
RAID10.
Pensavamo di notare una differenza notevole sulle VM (usiamo thinclient
con Horizon) ma così non è stato.
Al momento siamo in una situazione di test dove abbiamo l'host ESXI
(5.5u2) in direct-attach a 10Gb con la scheda intel X540at2 con il
synology. Abbiamo abilitato i Jumbo Frame su iSCSI
Il datastore non veniva visto come SSD da ESXi, abbiamo dovuto
modificare manualmente i flag per far si che l'host abilitasse il flag
SSD.
I test effettuati sono stati i seguenti:
Cache sul datastore RAID: Nessun miglioramento
Spostata VM su datastore SSD: Nessun miglioramento
Creazione di un disco D: e copia/sposta ******* tra i due dischi, picco a
500MB di qualche secondo per poi stare su una media di 210/220MB
Test del disco con HD Tune, tempi di accesso medi tra 0.3 e 0.6 ms e
trasferimento in lettura 110MB/s in lettura e 160MB/s in Scrittura con i
test RAW mentre con i ******* test si raggiungono i 500MB/s in lettura e i
340MB/s in scrittura
Non sappiamo più dove sbattere la testa, qualcuno ha esperienza in
merito? qualche consiglio, dritta?




--
Giocare col mondo, facendolo a pezzi...
Bambini che il sole, ha ridotto gia'... vecchi.
Beppe 25 Lug 2015 11:40
Domanda stupida la mia: la rete dati è isolata da quella di storage? Non
vorrei ci fosse troppo traffico (broadcast?) che impedisce le buone
prestazioni dell'iSCSI. Se è possibile sarebbe anche il caso di fare un
test diretto sullo storage usando ad esempio una macchina linux
installata al posto di uno degli ESXi.
Un'altra cosa nel mio caso (Dell) mi hanno sconsigliato di abilitare i
jumbo frames con la scheda di rete a 10G broadcom perchè non compatibili
con l'offload, magari nelle doc della intel c'è qualcosa di *****ogo.

PS non sono un esperto ma questi sono i test e le cose che cercherei io
writethem 25 Lug 2015 13:04
> Creazione di un disco D: e copia/sposta ******* tra i due dischi, picco a
> 500MB di qualche secondo per poi stare su una media di 210/220MB

premesso che sto approfondendo l'argomento "storage performance" solo
adesso e che sto aspettando un NAS SSD a giorni per farci tutti i test
possibili e immaginabili (con anche la tua scheda 10gbe), ti riporto
qualche impressione:

- 220MB di spostamento su se stesso significa quindi 440MB di traffico
sulla NIC. è poco, ma non pochissimo, dai un'occhio qui:

https://www.qnap.com/i/it/product_x_performance/product.php?type=7&II=124

ci sono i performance test di qnap fatti nella condizione più
vantaggiosa possibile (100% write o 100% read)

- sempre al link di cui sopra, osserva come cambia la situazione
aggregando più 10Gbit, secondo me per uno storage full SSD 1x10Gb
potrebbe non essere sufficiente, io mi orienterei almeno su 2 NIC
(storage permettendo). Il collo di bottiglia, teoricamente, dovrebbe
essere la parte network.

- sempre al link di cui sopra, in fondo vedi come hanno condotto i test
e prendi spunto per migliorare le performance, ad esempio abilita i
jumboframe. non ricordo dove (anche io ho inserito qualche discussione
su storage & co.), ho letto dei performance test tra una scheda iscsi
*****ware indipendent senza jumbo frame e una scheda normale con iscsi
software ma con jumbo frame, e questo secondo caso è stato persino
migliorativo.

Links
Giochi online
Dizionario sinonimi
Leggi e codici
Ricette
Testi
Webmatica
Hosting gratis
   
 

Sistemi di virtualizzazione | Tutti i gruppi | it.comp.virtualizzazione | Notizie e discussioni virtualizzazione | Virtualizzazione Mobile | Servizio di consultazione news.